<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0" />
<title>Registration Open for Travel Centres Conference - ITTN</title>
<link rel="shortcut icon" href="https://ittn.ie/wp-content/uploads/2021/01/ittnlogo.png" /><link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="https://ittn.ie/feed/" />
<link rel="alternate" type="text/xml" title="RSS .92" href="https://ittn.ie/feed/rss/" />
<link rel="alternate" type="application/atom+xml" title="Atom 0.3" href="https://ittn.ie/feed/atom/" />
<link rel="pingback" href="https://ittn.ie/xmlrpc.php" />
<meta property="og:image" content="https://ittn.ie/wp-content/uploads/2021/09/Travel-Centre-Logo-2014.jpg" />
<meta property="og:type" content="article" />
<meta property="og:description" content="Registration is now open for this year’s Travel Centres conference which takes place on Saturday, 13 November, 2021. The consortium has decided to condense what is normally a two-day event [&hellip;]" />
<link rel="author" href="" />
<meta name="facebook-domain-verification" content="w94nqalzh9btb6v1hlhwnqti6pf90k" />
<meta property="fb:pages" content="124731470873423" />

<script>
!function(f,b,e,v,n,t,s)
{if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};
if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];
s.parentNode.insertBefore(t,s)}(window,document,'script',
'https://connect.facebook.net/en_US/fbevents.js');
 fbq('init', '320394092685415'); 
fbq('track', 'PageView');
</script>
<noscript>
 <img height="1" width="1" 
src="https://www.facebook.com/tr?id=320394092685415&ev=PageView
&noscript=1"/>
</noscript>
<script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-24217449-1']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<meta property="og:title" content="Registration Open for Travel Centres Conference" />
<meta property="og:description" content="Registration is now open for this year’s Travel Centres conference which takes place on Saturday, 13 November, 2021.  The consortium has decided to condense" />
<meta property="og:image" content="https://ittn.ie/wp-content/uploads/2021/09/Travel-Centre-Logo-2014.jpg" />
<meta property="og:image:width" content="994" />
<meta property="og:image:height" content="198" />
<meta name="twitter:card" content="summary">
<meta name="twitter:title" content="Registration Open for Travel Centres Conference" />
<meta name="twitter:description" content="Registration is now open for this year’s Travel Centres conference which takes place on Saturday, 13 November, 2021.  The consortium has decided to condense" />
<meta name="twitter:image" content="https://ittn.ie/wp-content/uploads/2021/09/Travel-Centre-Logo-2014.jpg" />
<meta name="author" content="Fionn Davenport" />

<link rel="canonical" href="https://ittn.ie/news/registration-open-for-travel-centres-conference/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://ittn.ie/news/registration-open-for-travel-centres-conference/" />
<meta property="og:site_name" content="ITTN" />
<meta property="article:published_time" content="2021-09-07T12:48:43+00:00" />
<meta property="article:modified_time" content="2021-09-07T14:08:29+00:00" />
<meta property="og:image" content="https://ittn.ie/wp-content/uploads/2021/09/Travel-Centre-Logo-2014.jpg" />
<meta property="og:image:width" content="994" />
<meta property="og:image:height" content="198" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://ittn.ie/#website","url":"https://ittn.ie/","name":"ITTN","description":"","potentialAction":[{"@type":"SearchAction","target":"https://ittn.ie/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://ittn.ie/news/registration-open-for-travel-centres-conference/#primaryimage","inLanguage":"en-US","url":"https://ittn.ie/wp-content/uploads/2021/09/Travel-Centre-Logo-2014.jpg","contentUrl":"https://ittn.ie/wp-content/uploads/2021/09/Travel-Centre-Logo-2014.jpg","width":994,"height":198},{"@type":"WebPage","@id":"https://ittn.ie/news/registration-open-for-travel-centres-conference/#webpage","url":"https://ittn.ie/news/registration-open-for-travel-centres-conference/","name":"Registration Open for Travel Centres Conference - ITTN","isPartOf":{"@id":"https://ittn.ie/#website"},"primaryImageOfPage":{"@id":"https://ittn.ie/news/registration-open-for-travel-centres-conference/#primaryimage"},"datePublished":"2021-09-07T12:48:43+00:00","dateModified":"2021-09-07T14:08:29+00:00","author":{"@id":"https://ittn.ie/#/schema/person/50ef4ada81055249d8e455234e777763"},"breadcrumb":{"@id":"https://ittn.ie/news/registration-open-for-travel-centres-conference/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://ittn.ie/news/registration-open-for-travel-centres-conference/"]}]},{"@type":"BreadcrumbList","@id":"https://ittn.ie/news/registration-open-for-travel-centres-conference/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://ittn.ie/","url":"https://ittn.ie/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://ittn.ie/news/registration-open-for-travel-centres-conference/","url":"https://ittn.ie/news/registration-open-for-travel-centres-conference/","name":"Registration Open for Travel Centres Conference"}}]},{"@type":"Person","@id":"https://ittn.ie/#/schema/person/50ef4ada81055249d8e455234e777763","name":"Fionn Davenport","image":{"@type":"ImageObject","@id":"https://ittn.ie/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/2e3cceb0fc3064245022d4b867291581?s=96&d=blank&r=g","contentUrl":"https://secure.gravatar.com/avatar/2e3cceb0fc3064245022d4b867291581?s=96&d=blank&r=g","caption":"Fionn Davenport"},"description":"Fionn Davenport is the editor-in-chief of the ITTN group, including ITTN and ITTN Ireland. He's one of Ireland's best-known travel journalists and writers, with nearly 30 years' experience writing guidebooks for Lonely Planet and others."}]}</script>

<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="ITTN &raquo; Feed" href="https://ittn.ie/feed/" />
<link rel="alternate" type="application/rss+xml" title="ITTN &raquo; Comments Feed" href="https://ittn.ie/comments/feed/" />
<link rel="alternate" type="text/calendar" title="ITTN &raquo; iCal Feed" href="https://ittn.ie/all-events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="ITTN &raquo; Registration Open for Travel Centres Conference Comments Feed" href="https://ittn.ie/news/registration-open-for-travel-centres-conference/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/ittn.ie\/wp-includes\/js\/wp-emoji-release.min.js?ver=42"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='tribe-common-skeleton-style-css' href='https://ittn.ie/wp-content/plugins/the-events-calendar/common/src/resources/css/common-skeleton.min.css?ver=4.13.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-tooltip-css' href='https://ittn.ie/wp-content/plugins/the-events-calendar/common/src/resources/css/tooltip.min.css?ver=4.13.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://ittn.ie/wp-includes/css/dist/block-library/style.min.css?ver=5.7.2' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='forms-for-campaign-monitor-custom_cm_monitor_css-css' href='https://ittn.ie/wp-content/plugins/forms-for-campaign-monitor/forms/views/public/css/app.css?ver=1.0.0' type='text/css' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='iecss-css'  href='https://ittn.ie/wp-content/themes/ittn-2015/css/iecss.css?ver=5.7.2' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='mvp-style-css' href='https://ittn.ie/wp-content/themes/ittn-2015/style.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='reset-css' href='https://ittn.ie/wp-content/themes/ittn-2015/css/reset.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css' href='//maxcdn.bootstrapcdn.com/font-awesome/4.3.0/css/font-awesome.min.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='media-queries-css' href='https://ittn.ie/wp-content/themes/ittn-2015/css/media-queries.css?ver=5.7.2' type='text/css' media='all' />
<style id="googlefonts-css" media="screen">@font-face {
  font-family: 'Open Sans';
  font-style: normal;
  font-weight: 700;
  src: url(/fonts.gstatic.com/s/opensans/v23/mem5YaGs126MiZpBA-UN7rgOUuhs.ttf) format('truetype');
}
@font-face {
  font-family: 'Open Sans';
  font-style: normal;
  font-weight: 800;
  src: url(/fonts.gstatic.com/s/opensans/v23/mem5YaGs126MiZpBA-UN8rsOUuhs.ttf) format('truetype');
}
</style>
<link rel='stylesheet' id='jetpack_css-css' href='https://ittn.ie/wp-content/plugins/jetpack/css/jetpack.css?ver=9.6.2' type='text/css' media='all' />
<script type='text/javascript' src='https://ittn.ie/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://ittn.ie/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<link rel="https://api.w.org/" href="https://ittn.ie/wp-json/" /><link rel="alternate" type="application/json" href="https://ittn.ie/wp-json/wp/v2/posts/70021" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://ittn.ie/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://ittn.ie/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://ittn.ie/?p=70021' />
<link rel="alternate" type="application/json+oembed" href="https://ittn.ie/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fittn.ie%2Fnews%2Fregistration-open-for-travel-centres-conference%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://ittn.ie/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fittn.ie%2Fnews%2Fregistration-open-for-travel-centres-conference%2F&#038;format=xml" />
<meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://ittn.ie"><link rel="https://theeventscalendar.com/" href="https://ittn.ie/wp-json/tribe/events/v1/" />
<style type='text/css'>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</style>
<style type="text/css">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</style>
<style type="text/css">
</style>
<style type="text/css" id="custom-background-css">
body.custom-background { background-image: url("https://ittn.ie/wp-content/uploads/2015/05/gray-bg.jpg"); background-position: left top; background-size: auto; background-repeat: repeat; background-attachment: scroll; }
</style>
</head>
<body class="post-template-default single single-post postid-70021 single-format-standard custom-background tribe-no-js page-template-var-www-ittn-ie-htdocs-wp-content-themes-ittn-2015-page-php">
<div id="wallpaper">
<a href="http://itt.network/www/delivery/cl.php?zoneid=31" class="wallpaper-link" target="_blank"></a>
</div>
<div id="site">
<header>
<div id="nav-wrap" class="left relative">
<div class="content-out">
<div class="content-in">
<div id="nav-contain" class="left">
<div id="nav-contain-out">
<div id="nav-logo" class="left" itemscope itemtype="http://schema.org/Organization">
<a itemprop="url" href="https://ittn.ie"><img itemprop="logo" src="https://ittn.ie/wp-content/uploads/2021/04/ittnlogo_2_optimised.jpg" alt="ITTN" /></a>
</div>
<div id="nav-contain-in">
<div id="main-nav-out">
<div id="main-nav-in">
<nav>
<div id="mobile-menu-wrap" class="left relative">
<i class="fa fa-bars fa-3"></i>
<div id="mobile-nav">
<div class="menu-2015-menu-container"><select><option value="#">Menu</option><option value="https://ittn.ie/all-events/" id="menu-item-65195">Events</option>
<option value="https://ittn.ie/about/" id="menu-item-25676">About	<option value="https://ittn.ie/contact/" id="menu-item-25408">-Contact</option>
<option value="https://ittn.ie/about/" id="menu-item-25410">-About ITTN</option>
<option value="https://ittn.ie/jobs/" id="menu-item-66740">-Industry Jobs</option>
<option value="https://ittn.ie/editorial-team/" id="menu-item-25682">-Meet the Team</option>
<option value="https://ittn.ie/marketing/" id="menu-item-25409">-Advertising</option>
<option value="https://ittn.ie/privacy-policy/" id="menu-item-25693">-Privacy Policy</option>
<option value="https://ittn.ie/disclaimer/" id="menu-item-25694">-Disclaimer</option>
<option value="https://ittn.ie/news/" id="menu-item-25405">-News</option>
<option value="https://ittn.ie/ireland/" id="menu-item-63505">-ITTN Ireland</option>
</option>
<option value="https://ittn.ie/irelands-travel-trade-network-awards/" id="menu-item-61818">ITTN Awards 2021	<option value="https://ittn.ie/2019-irish-travel-trade-awards/" id="menu-item-61819">-2019 Irish Travel Trade Awards</option>
</option>
<option value="https://ittn.ie/ittn-photographer-of-the-year/" id="menu-item-61832">ITTN Photographer of the Year	<option value="https://ittn.ie/2021-entries/" id="menu-item-54803">-2021 Entries</option>
<option value="https://ittn.ie/2019-entries/" id="menu-item-62180">-2019 Entries</option>
<option value="https://ittn.ie/2018-ittn-travel-photographer-of-the-year-competition-entries/" id="menu-item-47427">-2018 Entries</option>
<option value="https://ittn.ie/2017-ittn-travel-photographer-of-the-year-competition/" id="menu-item-40379">-2017 Entries</option>
<option value="https://ittn.ie/travel-photographer-of-the-year-competition-entries/" id="menu-item-33534">-2016 Entries</option>
<option value="https://ittn.ie/travel-photographer-of-the-year-entries/" id="menu-item-26866">-2015 Entries</option>
</option>
</select></div> </div>
</div>
<div id="nav-out">
<div id="nav-in">
<div class="main-nav left main-nav-contain">
<div class="main-nav-in left">
<div class="menu-2015-menu-container"><ul id="menu-2015-menu-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-65195"><a href="https://ittn.ie/all-events/">Events</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-25676"><a href="https://ittn.ie/about/">About</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-25408"><a href="https://ittn.ie/contact/">Contact</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-25410"><a href="https://ittn.ie/about/">About ITTN</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66740"><a href="https://ittn.ie/jobs/">Industry Jobs</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-25682"><a href="https://ittn.ie/editorial-team/">Meet the Team</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-25409"><a href="https://ittn.ie/marketing/">Advertising</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-25693"><a href="https://ittn.ie/privacy-policy/">Privacy Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-25694"><a href="https://ittn.ie/disclaimer/">Disclaimer</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-25405"><a href="https://ittn.ie/news/">News</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-63505"><a href="https://ittn.ie/ireland/">ITTN Ireland</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-61818"><a href="https://ittn.ie/irelands-travel-trade-network-awards/">ITTN Awards 2021</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61819"><a href="https://ittn.ie/2019-irish-travel-trade-awards/">2019 Irish Travel Trade Awards</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-61832"><a href="https://ittn.ie/ittn-photographer-of-the-year/">ITTN Photographer of the Year</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54803"><a href="https://ittn.ie/2021-entries/">2021 Entries</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-62180"><a href="https://ittn.ie/2019-entries/">2019 Entries</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-47427"><a href="https://ittn.ie/2018-ittn-travel-photographer-of-the-year-competition-entries/">2018 Entries</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40379"><a href="https://ittn.ie/2017-ittn-travel-photographer-of-the-year-competition/">2017 Entries</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33534"><a href="https://ittn.ie/travel-photographer-of-the-year-competition-entries/">2016 Entries</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-26866"><a href="https://ittn.ie/travel-photographer-of-the-year-entries/">2015 Entries</a></li>
</ul>
</li>
</ul></div> </div>
</div>
</div>
</div>
</nav>
</div>
<div class="nav-spacer"></div>
<div id="nav-right">
<div id="search-button">
<i class="fa fa-search fa-2"></i>
</div>
<div id="social-nav" class="relative">
<span class="fb-nav"><i class="fa fa-facebook fa-2"></i></span>
<span class="twit-nav"><i class="fa fa-twitter fa-2"></i></span>
<span class="plus-nav"><i class="fa fa-plus fa-2"></i></span>
<div id="social-dropdown">
<ul class="social-drop-list relative">
<a href="https://www.facebook.com/IrishTravelTradeNews" alt="Facebook" target="_blank">
<li class="fb-drop">
<i class="fa fa-facebook-square fa-2"></i>
<p>Facebook</p>
</li>
</a>
<a href="https://twitter.com/@ittn_ie" alt="Twitter" target="_blank">
<li class="twit-drop">
<i class="fa fa-twitter fa-2"></i>
<p>Twitter</p>
</li>
</a>
<a href="https://www.instagram.com/ittn.ie/" alt="Instagram" target="_blank">
<li class="inst-drop">
<i class="fa fa-instagram fa-2"></i>
<p>Instagram</p>
</li>
</a>
<a href="https://www.youtube.com/channel/UCsikaeVh5hJ4RIARpVkFnog" alt="Youtube" target="_blank">
<li class="yt-drop">
<i class="fa fa-youtube-play fa-2"></i>
<p>YouTube</p>
</li>
</a>
<a href="https://www.linkedin.com/company/irish-travel-trade-news/" alt="LinkedIn" target="_blank">
<li class="link-drop">
<i class="fa fa-linkedin fa-2"></i>
<p>LinkedIn</p>
</li>
</a>
<a href="https://ittn.ie/feed/rss/" target="_blank">
<li class="rss-drop">
<i class="fa fa-rss fa-2"></i>
<p>RSS</p>
</li>
</a>
</ul>
</div>
</div>
</div>
<div id="search-bar">
<form method="get" id="searchform" action="https://ittn.ie/">
<input type="text" name="s" id="s" value="Type search term and press enter" onfocus='if (this.value == "Type search term and press enter") { this.value = ""; }' onblur='if (this.value == "") { this.value = "Type search term and press enter"; }' />
<input type="hidden" id="searchsubmit" value="Search" />
</form> </div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</header>
<div id="head-wrap" class="left relative">
 <div class="head-wrap-out">
<div class="head-wrap-in">
<div class="content-out">
<div class="content-in">
<div id="leader-wrapper" class="left relative">


<ins data-revive-zoneid="1" data-revive-id="7d44df2311a99ecdba9e72b635283678"></ins>
<script async src="//itt.network/www/delivery/asyncjs.php"></script>
</div>
</div>
</div>
<div class="content-out">
<div class="content-in">
</div>
</div>
</div>
</div>
</div>
<div id="content-wrapper" class="left relative social-bottom">
<div class="content-out" class="relative">
<div class="content-in" itemscope itemtype="http://schema.org/Article">
<div id="post-social-out" class="relative">
<div id="post-social-wrap">
<ul class="post-social-list left relative">
<li class="post-social-fb">
<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://ittn.ie/news/registration-open-for-travel-centres-conference/&amp;t=Registration Open for Travel Centres Conference', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><i class="fa fa-facebook fa-2"></i></a>
</li>
<li class="post-social-twit">
<a href="#" onclick="window.open('http://twitter.com/share?text=Registration Open for Travel Centres Conference&amp;url=https://ittn.ie/news/registration-open-for-travel-centres-conference/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><i class="fa fa-twitter fa-2"></i></a>
</li>
<li class="post-social-pin">
<a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://ittn.ie/news/registration-open-for-travel-centres-conference/&amp;media=https://ittn.ie/wp-content/uploads/2021/09/Travel-Centre-Logo-2014.jpg&amp;description=Registration Open for Travel Centres Conference', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"><i class="fa fa-pinterest fa-2"></i></a>
</li>
<li class="post-social-goog">
<a href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&amp;url=https://ittn.ie/news/registration-open-for-travel-centres-conference/', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank"><i class="fa fa-google-plus fa-2"></i></a>
</li>
<li class="post-social-comm">
<a href="https://ittn.ie/news/registration-open-for-travel-centres-conference/#respond" class="comment-click"><i class="fa fa-comments fa-2"></i></a>
</li>
</ul>
</div>
<div id="post-social-in">
<div id="post-content-out">
<div id="post-content-in">
<div id="post-content-contain" class="left relative">
<article class="post-70021 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-conference tag-featured tag-travel-centres">
<div id="post-content-wrapper" class="relative">
<div id="post-area" class="left relative">
<div class="post-cat-contain left relative post-cat-mob">
<span class="img-cat left">News</span>
</div>
<h1 class="story-title entry-title" itemprop="name headline">Registration Open for Travel Centres Conference</h1>
<div id="right-content" class="relative">
<div id="content-area" class="left relative" itemprop="articleBody">
<div id="feat-img-reg" class="relative">
<img itemprop="image" src="https://ittn.ie/wp-content/uploads/2021/09/Travel-Centre-Logo-2014.jpg" />
</div>
 <div class="hide-title">
<span class="entry-title" itemprop="name headline">Registration Open for Travel Centres Conference</span>
</div>
<div id="left-content-mobi">
<div class="author-img left">
<img alt='' src='https://secure.gravatar.com/avatar/2e3cceb0fc3064245022d4b867291581?s=120&#038;d=blank&#038;r=g' srcset='https://secure.gravatar.com/avatar/2e3cceb0fc3064245022d4b867291581?s=240&#038;d=blank&#038;r=g 2x' class='avatar avatar-120 photo' height='120' width='120' loading='lazy' /> </div>
<div class="author-info-mob-wrap">
<span class="vcard author">
<span class="author-name left fn" itemprop="author"><a href="https://ittn.ie/author/fionndavenportittn/" title="Posts by Fionn Davenport" rel="author">Fionn Davenport</a></span>
</span>
<div class="post-date-wrap left relative post-date-mob">
<span class="post-date"><time class="post-date updated" itemprop="datePublished" datetime="2021-09-07" pubdate>September 7, 2021</time></span>
</div>
</div>
</div>
<p>Registration is now open for this year’s Travel Centres conference which takes place on Saturday, 13 November, 2021.</p>
<p>The consortium has decided to condense what is normally a two-day event into just one day so as to minimise the cost of attending for all delegates.</p>
<p>This year’s event, the 16<sup>th</sup> for Travel Centres, takes place again at the Killashee House Hotel which is located just outside Naas.</p>
<p>Conference programme details will be announced in due course.</p>
<div id="article-ad">


<ins data-revive-zoneid="2" data-revive-id="7d44df2311a99ecdba9e72b635283678"></ins>
<script async src="//itt.network/www/delivery/asyncjs.php"></script>
</div>
<div class="post-tags post-tags-mobi">
<span class="post-tags-header">Related Items</span><span itemprop="keywords"><a href="https://ittn.ie/tag/conference/" rel="tag">Conference</a><a href="https://ittn.ie/tag/featured/" rel="tag">Featured</a><a href="https://ittn.ie/tag/travel-centres/" rel="tag">Travel Centres</a></span>
</div>
</div>
<div id="comments-button" class="left relative comment-click">
<span class="comment-but-text"><i class="fa fa-comments fa-2"></i> Click to add a comment</span>
</div>
<div id="comments">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title"><h4 class="post-header"><span class="post-header">Leave a Reply</span></h4> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/news/registration-open-for-travel-centres-conference/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://ittn.ie/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='70021' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="1561b55738" /></p><input type="hidden" id="ak_js" name="ak_js" value="219" /><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" style="display: none !important;"></textarea></form> </div>
</div> </div>
<div id="left-content" class="left relative">
<div class="post-cat-contain left relative">
<span class="img-cat left">News</span>
</div>
<div class="post-date-wrap left relative post-date-reg">
<span class="post-date"><time class="post-date updated" itemprop="datePublished" datetime="2021-09-07" pubdate>September 7, 2021</time></span>
</div>
<div class="author-info-wrap left relative">
<div class="author-img left">
<img alt='' src='https://secure.gravatar.com/avatar/2e3cceb0fc3064245022d4b867291581?s=120&#038;d=blank&#038;r=g' srcset='https://secure.gravatar.com/avatar/2e3cceb0fc3064245022d4b867291581?s=240&#038;d=blank&#038;r=g 2x' class='avatar avatar-120 photo' height='120' width='120' loading='lazy' /> </div>
<span class="vcard author">
<span class="author-name left fn" itemprop="author"><a href="https://ittn.ie/author/fionndavenportittn/" title="Posts by Fionn Davenport" rel="author">Fionn Davenport</a></span>
</span>
<p class="author-desc left">Fionn Davenport is the editor-in-chief of the ITTN group, including ITTN and ITTN Ireland. He's one of Ireland's best-known travel journalists and writers, with nearly 30 years' experience writing guidebooks for Lonely Planet and others.</p>
</div>
<div class="post-tags">
<span class="post-tags-header">Related Items</span><span itemprop="keywords"><a href="https://ittn.ie/tag/conference/" rel="tag">Conference</a><a href="https://ittn.ie/tag/featured/" rel="tag">Featured</a><a href="https://ittn.ie/tag/travel-centres/" rel="tag">Travel Centres</a></span>
</div>
</div>
</div>
</div>
</article>
<div id="post-latest-header" class="left relative">
<h4 class="post-latest left relative">More in News</h4>
</div>
<div id="post-latest-wrap" class="left relative infinite-content">
<div class="story-contain left relative infinite-post">
<a href="https://ittn.ie/news/loganair-restarts-dublin-aberdeen-route/" rel="bookmark">
<div class="story-contain-img left">
<img width="400" height="240" src="https://ittn.ie/wp-content/uploads/2021/09/Embraer-145-hi-res18-400x240.jpg" class="attachment-medium-thumb size-medium-thumb wp-post-image" alt="" loading="lazy" srcset="https://ittn.ie/wp-content/uploads/2021/09/Embraer-145-hi-res18-400x240.jpg 400w, https://ittn.ie/wp-content/uploads/2021/09/Embraer-145-hi-res18-460x276.jpg 460w, https://ittn.ie/wp-content/uploads/2021/09/Embraer-145-hi-res18-500x300.jpg 500w" sizes="(max-width: 400px) 100vw, 400px" /> </div>
<div class="story-contain-text">
<h2>Loganair Restarts Dublin-Aberdeen Route</h2>
<div class="text-info-contain left relative">
<span class="home-text-author left">Fionn Davenport</span><span class="home-text-date left">September 7, 2021</span>
</div>
</div>
</a>
<div class="read-share-overlay">
<div class="read-more-box-wrapper">
<a href="https://ittn.ie/news/loganair-restarts-dublin-aberdeen-route/" rel="bookmark"><span class="read-more-box">Read More</span></a>
</div>
<div class="share-box-wrapper">
<div class="read-more-fb">
<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://ittn.ie/news/loganair-restarts-dublin-aberdeen-route/&amp;t=Loganair Restarts Dublin-Aberdeen Route', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><i class="fa fa-facebook fa-2"></i></a>
</div>
<div class="read-more-twit">
<a href="#" onclick="window.open('http://twitter.com/share?text=Loganair Restarts Dublin-Aberdeen Route -&amp;url=https://ittn.ie/news/loganair-restarts-dublin-aberdeen-route/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><i class="fa fa-twitter fa-2"></i></a>
</div>
<div class="read-more-comment">
<a href="https://ittn.ie/news/loganair-restarts-dublin-aberdeen-route//#comments-button"><i class="fa fa-comments fa-2"></i></a>
</div>
</div>
</div>
</div>
<div class="story-contain left relative infinite-post">
<a href="https://ittn.ie/news/celebrity-cruises-unveils-25000-prize-giveaway-for-travel-agents/" rel="bookmark">
<div class="story-contain-img left">
<img width="351" height="237" src="https://ittn.ie/wp-content/uploads/2021/09/celebrity-agents.png" class="attachment-medium-thumb size-medium-thumb wp-post-image" alt="" loading="lazy" srcset="https://ittn.ie/wp-content/uploads/2021/09/celebrity-agents.png 351w, https://ittn.ie/wp-content/uploads/2021/09/celebrity-agents-300x203.png 300w" sizes="(max-width: 351px) 100vw, 351px" /> </div>
<div class="story-contain-text">
<h2>Celebrity Cruises Unveils £25,000 Prize Giveaway for Travel Agents</h2>
<div class="text-info-contain left relative">
<span class="home-text-author left">Fionn Davenport</span><span class="home-text-date left">September 7, 2021</span>
</div>
</div>
</a>
<div class="read-share-overlay">
<div class="read-more-box-wrapper">
<a href="https://ittn.ie/news/celebrity-cruises-unveils-25000-prize-giveaway-for-travel-agents/" rel="bookmark"><span class="read-more-box">Read More</span></a>
</div>
<div class="share-box-wrapper">
<div class="read-more-fb">
<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://ittn.ie/news/celebrity-cruises-unveils-25000-prize-giveaway-for-travel-agents/&amp;t=Celebrity Cruises Unveils £25,000 Prize Giveaway for Travel Agents', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><i class="fa fa-facebook fa-2"></i></a>
</div>
<div class="read-more-twit">
<a href="#" onclick="window.open('http://twitter.com/share?text=Celebrity Cruises Unveils £25,000 Prize Giveaway for Travel Agents -&amp;url=https://ittn.ie/news/celebrity-cruises-unveils-25000-prize-giveaway-for-travel-agents/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><i class="fa fa-twitter fa-2"></i></a>
</div>
<div class="read-more-comment">
<a href="https://ittn.ie/news/celebrity-cruises-unveils-25000-prize-giveaway-for-travel-agents//#comments-button"><i class="fa fa-comments fa-2"></i></a>
</div>
</div>
</div>
</div>
<div class="story-contain left relative infinite-post">
<a href="https://ittn.ie/news/tuesday-travel-tips-malta-with-sharon-jordan-of-ittn-roisin-carbery-of-tropical-sky/" rel="bookmark">
<div class="story-contain-img left">
<img width="400" height="240" src="https://ittn.ie/wp-content/uploads/2021/03/Travel-tips-400x240.png" class="attachment-medium-thumb size-medium-thumb wp-post-image" alt="" loading="lazy" srcset="https://ittn.ie/wp-content/uploads/2021/03/Travel-tips-400x240.png 400w, https://ittn.ie/wp-content/uploads/2021/03/Travel-tips-300x180.png 300w, https://ittn.ie/wp-content/uploads/2021/03/Travel-tips-768x461.png 768w, https://ittn.ie/wp-content/uploads/2021/03/Travel-tips-460x276.png 460w, https://ittn.ie/wp-content/uploads/2021/03/Travel-tips-500x300.png 500w, https://ittn.ie/wp-content/uploads/2021/03/Travel-tips.png 1000w" sizes="(max-width: 400px) 100vw, 400px" /> </div>
<div class="story-contain-text">
<h2>Tuesday Travel Tips: Malta with Sharon Jordan of ITTN &amp; Roisin Carbery of Tropical Sky</h2>
<div class="text-info-contain left relative">
<span class="home-text-author left">Leona Kenny</span><span class="home-text-date left">September 7, 2021</span>
</div>
</div>
</a>
<div class="read-share-overlay">
<div class="read-more-box-wrapper">
<a href="https://ittn.ie/news/tuesday-travel-tips-malta-with-sharon-jordan-of-ittn-roisin-carbery-of-tropical-sky/" rel="bookmark"><span class="read-more-box">Read More</span></a>
</div>
<div class="share-box-wrapper">
<div class="read-more-fb">
<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://ittn.ie/news/tuesday-travel-tips-malta-with-sharon-jordan-of-ittn-roisin-carbery-of-tropical-sky/&amp;t=Tuesday Travel Tips: Malta with Sharon Jordan of ITTN &amp; Roisin Carbery of Tropical Sky', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><i class="fa fa-facebook fa-2"></i></a>
</div>
<div class="read-more-twit">
<a href="#" onclick="window.open('http://twitter.com/share?text=Tuesday Travel Tips: Malta with Sharon Jordan of ITTN &amp; Roisin Carbery of Tropical Sky -&amp;url=https://ittn.ie/news/tuesday-travel-tips-malta-with-sharon-jordan-of-ittn-roisin-carbery-of-tropical-sky/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><i class="fa fa-twitter fa-2"></i></a>
</div>
<div class="read-more-comment">
<a href="https://ittn.ie/news/tuesday-travel-tips-malta-with-sharon-jordan-of-ittn-roisin-carbery-of-tropical-sky//#comments-button"><i class="fa fa-comments fa-2"></i></a>
</div>
</div>
</div>
</div>
<div class="story-contain left relative infinite-post">
<a href="https://ittn.ie/news/ittn-ireland-gets-a-new-name-logo-welcome-to-travel2ireland/" rel="bookmark">
<div class="story-contain-img left">
<img width="400" height="216" src="https://ittn.ie/wp-content/uploads/2021/09/travel2irelandlogo-400x216.png" class="attachment-medium-thumb size-medium-thumb wp-post-image" alt="" loading="lazy" /> </div>
<div class="story-contain-text">
<h2>ITTN Ireland Gets a New Name &amp; Logo: Welcome to Travel2Ireland</h2>
<div class="text-info-contain left relative">
<span class="home-text-author left">Fionn Davenport</span><span class="home-text-date left">September 7, 2021</span>
</div>
</div>
</a>
<div class="read-share-overlay">
<div class="read-more-box-wrapper">
<a href="https://ittn.ie/news/ittn-ireland-gets-a-new-name-logo-welcome-to-travel2ireland/" rel="bookmark"><span class="read-more-box">Read More</span></a>
</div>
<div class="share-box-wrapper">
<div class="read-more-fb">
<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://ittn.ie/news/ittn-ireland-gets-a-new-name-logo-welcome-to-travel2ireland/&amp;t=ITTN Ireland Gets a New Name &amp; Logo: Welcome to Travel2Ireland', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><i class="fa fa-facebook fa-2"></i></a>
</div>
<div class="read-more-twit">
<a href="#" onclick="window.open('http://twitter.com/share?text=ITTN Ireland Gets a New Name &amp; Logo: Welcome to Travel2Ireland -&amp;url=https://ittn.ie/news/ittn-ireland-gets-a-new-name-logo-welcome-to-travel2ireland/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><i class="fa fa-twitter fa-2"></i></a>
</div>
<div class="read-more-comment">
<a href="https://ittn.ie/news/ittn-ireland-gets-a-new-name-logo-welcome-to-travel2ireland//#comments-button"><i class="fa fa-comments fa-2"></i></a>
</div>
</div>
</div>
</div>
<div class="story-contain left relative infinite-post">
<a href="https://ittn.ie/news/air-canada-launches-new-trip-planning-tool/" rel="bookmark">
<div class="story-contain-img left">
<img width="400" height="240" src="https://ittn.ie/wp-content/uploads/2021/01/B737_Max_Shoreline-air-canada-400x240.jpg" class="attachment-medium-thumb size-medium-thumb wp-post-image" alt="" loading="lazy" srcset="https://ittn.ie/wp-content/uploads/2021/01/B737_Max_Shoreline-air-canada-400x240.jpg 400w, https://ittn.ie/wp-content/uploads/2021/01/B737_Max_Shoreline-air-canada-460x276.jpg 460w, https://ittn.ie/wp-content/uploads/2021/01/B737_Max_Shoreline-air-canada-500x300.jpg 500w, https://ittn.ie/wp-content/uploads/2021/01/B737_Max_Shoreline-air-canada-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /> <div class="video-but-contain">
<i class="fa fa-play-circle-o fa-4"></i>
</div>
</div>
<div class="story-contain-text">
<h2>Air Canada Launches New Trip Planning Tool</h2>
<div class="text-info-contain left relative">
<span class="home-text-author left">Fionn Davenport</span><span class="home-text-date left">September 7, 2021</span>
</div>
</div>
</a>
<div class="read-share-overlay">
<div class="read-more-box-wrapper">
<a href="https://ittn.ie/news/air-canada-launches-new-trip-planning-tool/" rel="bookmark"><span class="read-more-box">Read More</span></a>
</div>
<div class="share-box-wrapper">
<div class="read-more-fb">
<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://ittn.ie/news/air-canada-launches-new-trip-planning-tool/&amp;t=Air Canada Launches New Trip Planning Tool', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><i class="fa fa-facebook fa-2"></i></a>
</div>
<div class="read-more-twit">
<a href="#" onclick="window.open('http://twitter.com/share?text=Air Canada Launches New Trip Planning Tool -&amp;url=https://ittn.ie/news/air-canada-launches-new-trip-planning-tool/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><i class="fa fa-twitter fa-2"></i></a>
</div>
<div class="read-more-comment">
<a href="https://ittn.ie/news/air-canada-launches-new-trip-planning-tool//#comments-button"><i class="fa fa-comments fa-2"></i></a>
</div>
</div>
</div>
</div>
<div class="story-contain left relative infinite-post">
<a href="https://ittn.ie/news/the-heat-is-on-aer-lingus-summer-2022-routes-on-sale-now/" rel="bookmark">
<div class="story-contain-img left">
<img width="400" height="240" src="https://ittn.ie/wp-content/uploads/2019/12/aerlingus_459108595250095-400x240.jpg" class="attachment-medium-thumb size-medium-thumb wp-post-image" alt="" loading="lazy" srcset="https://ittn.ie/wp-content/uploads/2019/12/aerlingus_459108595250095-400x240.jpg 400w, https://ittn.ie/wp-content/uploads/2019/12/aerlingus_459108595250095-460x276.jpg 460w, https://ittn.ie/wp-content/uploads/2019/12/aerlingus_459108595250095-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /> </div>
<div class="story-contain-text">
<h2>The Heat is On: Aer Lingus Summer 2022 Routes On Sale Now</h2>
<div class="text-info-contain left relative">
<span class="home-text-author left">Fionn Davenport</span><span class="home-text-date left">September 7, 2021</span>
</div>
</div>
</a>
<div class="read-share-overlay">
<div class="read-more-box-wrapper">
<a href="https://ittn.ie/news/the-heat-is-on-aer-lingus-summer-2022-routes-on-sale-now/" rel="bookmark"><span class="read-more-box">Read More</span></a>
</div>
<div class="share-box-wrapper">
<div class="read-more-fb">
<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://ittn.ie/news/the-heat-is-on-aer-lingus-summer-2022-routes-on-sale-now/&amp;t=The Heat is On: Aer Lingus Summer 2022 Routes On Sale Now', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><i class="fa fa-facebook fa-2"></i></a>
</div>
<div class="read-more-twit">
<a href="#" onclick="window.open('http://twitter.com/share?text=The Heat is On: Aer Lingus Summer 2022 Routes On Sale Now -&amp;url=https://ittn.ie/news/the-heat-is-on-aer-lingus-summer-2022-routes-on-sale-now/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><i class="fa fa-twitter fa-2"></i></a>
</div>
<div class="read-more-comment">
<a href="https://ittn.ie/news/the-heat-is-on-aer-lingus-summer-2022-routes-on-sale-now//#comments-button"><i class="fa fa-comments fa-2"></i></a>
</div>
</div>
</div>
</div>
<div class="story-contain left relative infinite-post">
<a href="https://ittn.ie/news/europes-hidden-highlights-on-newstalk-the-dalmatian-coast/" rel="bookmark">
<div class="story-contain-img left">
<img width="400" height="240" src="https://ittn.ie/wp-content/uploads/2021/09/spencer-davis-Dubrovnik-unsplash-400x240.jpg" class="attachment-medium-thumb size-medium-thumb wp-post-image" alt="" loading="lazy" srcset="https://ittn.ie/wp-content/uploads/2021/09/spencer-davis-Dubrovnik-unsplash-400x240.jpg 400w, https://ittn.ie/wp-content/uploads/2021/09/spencer-davis-Dubrovnik-unsplash-460x276.jpg 460w, https://ittn.ie/wp-content/uploads/2021/09/spencer-davis-Dubrovnik-unsplash-500x300.jpg 500w, https://ittn.ie/wp-content/uploads/2021/09/spencer-davis-Dubrovnik-unsplash-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" />  </div>
<div class="story-contain-text">
<h2>Europe&#8217;s Hidden Highlights on Newstalk: The Dalmatian Coast</h2>
<div class="text-info-contain left relative">
<span class="home-text-author left">Fionn Davenport</span><span class="home-text-date left">September 7, 2021</span>
</div>
</div>
</a>
<div class="read-share-overlay">
<div class="read-more-box-wrapper">
<a href="https://ittn.ie/news/europes-hidden-highlights-on-newstalk-the-dalmatian-coast/" rel="bookmark"><span class="read-more-box">Read More</span></a>
</div>
<div class="share-box-wrapper">
<div class="read-more-fb">
<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://ittn.ie/news/europes-hidden-highlights-on-newstalk-the-dalmatian-coast/&amp;t=Europe&#8217;s Hidden Highlights on Newstalk: The Dalmatian Coast', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><i class="fa fa-facebook fa-2"></i></a>
</div>
<div class="read-more-twit">
<a href="#" onclick="window.open('http://twitter.com/share?text=Europe&#8217;s Hidden Highlights on Newstalk: The Dalmatian Coast -&amp;url=https://ittn.ie/news/europes-hidden-highlights-on-newstalk-the-dalmatian-coast/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><i class="fa fa-twitter fa-2"></i></a>
</div>
<div class="read-more-comment">
<a href="https://ittn.ie/news/europes-hidden-highlights-on-newstalk-the-dalmatian-coast//#comments-button"><i class="fa fa-comments fa-2"></i></a>
</div>
</div>
</div>
</div>
<div class="story-contain left relative infinite-post">
<a href="https://ittn.ie/news/what-now-for-business-travel-some-of-the-mad-regular-dashes-across-the-atlantic-arent-necessary/" rel="bookmark">
<div class="story-contain-img left">
<img width="400" height="240" src="https://ittn.ie/wp-content/uploads/2019/06/WestJet-Rewards-‘Buy-Business-Get-Gold’-400x240.jpg" class="attachment-medium-thumb size-medium-thumb wp-post-image" alt="" loading="lazy" srcset="https://ittn.ie/wp-content/uploads/2019/06/WestJet-Rewards-‘Buy-Business-Get-Gold’-400x240.jpg 400w, https://ittn.ie/wp-content/uploads/2019/06/WestJet-Rewards-‘Buy-Business-Get-Gold’-300x180.jpg 300w, https://ittn.ie/wp-content/uploads/2019/06/WestJet-Rewards-‘Buy-Business-Get-Gold’-768x461.jpg 768w, https://ittn.ie/wp-content/uploads/2019/06/WestJet-Rewards-‘Buy-Business-Get-Gold’-460x276.jpg 460w, https://ittn.ie/wp-content/uploads/2019/06/WestJet-Rewards-‘Buy-Business-Get-Gold’.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /> </div>
<div class="story-contain-text">
<h2>What Now for Business Travel? &#8216;Some of the Mad Regular Dashes Across the Atlantic aren&#8217;t Necessary&#8217;</h2>
<div class="text-info-contain left relative">
<span class="home-text-author left">Fionn Davenport</span><span class="home-text-date left">September 7, 2021</span>
</div>
</div>
</a>
<div class="read-share-overlay">
<div class="read-more-box-wrapper">
<a href="https://ittn.ie/news/what-now-for-business-travel-some-of-the-mad-regular-dashes-across-the-atlantic-arent-necessary/" rel="bookmark"><span class="read-more-box">Read More</span></a>
</div>
<div class="share-box-wrapper">
<div class="read-more-fb">
<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://ittn.ie/news/what-now-for-business-travel-some-of-the-mad-regular-dashes-across-the-atlantic-arent-necessary/&amp;t=What Now for Business Travel? &#8216;Some of the Mad Regular Dashes Across the Atlantic aren&#8217;t Necessary&#8217;', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><i class="fa fa-facebook fa-2"></i></a>
</div>
<div class="read-more-twit">
<a href="#" onclick="window.open('http://twitter.com/share?text=What Now for Business Travel? &#8216;Some of the Mad Regular Dashes Across the Atlantic aren&#8217;t Necessary&#8217; -&amp;url=https://ittn.ie/news/what-now-for-business-travel-some-of-the-mad-regular-dashes-across-the-atlantic-arent-necessary/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><i class="fa fa-twitter fa-2"></i></a>
</div>
<div class="read-more-comment">
<a href="https://ittn.ie/news/what-now-for-business-travel-some-of-the-mad-regular-dashes-across-the-atlantic-arent-necessary//#comments-button"><i class="fa fa-comments fa-2"></i></a>
</div>
</div>
</div>
</div>
<div class="story-contain left relative infinite-post">
<a href="https://ittn.ie/news/aviation-authority-aims-to-achieve-carbon-neutral-status-by-2025/" rel="bookmark">
<div class="story-contain-img left">
<img width="400" height="240" src="https://ittn.ie/wp-content/uploads/2020/10/Cork-Airport-Aer-Lingus-and-Ryanair-400x240.jpg" class="attachment-medium-thumb size-medium-thumb wp-post-image" alt="" loading="lazy" srcset="https://ittn.ie/wp-content/uploads/2020/10/Cork-Airport-Aer-Lingus-and-Ryanair-400x240.jpg 400w, https://ittn.ie/wp-content/uploads/2020/10/Cork-Airport-Aer-Lingus-and-Ryanair-300x180.jpg 300w, https://ittn.ie/wp-content/uploads/2020/10/Cork-Airport-Aer-Lingus-and-Ryanair-768x461.jpg 768w, https://ittn.ie/wp-content/uploads/2020/10/Cork-Airport-Aer-Lingus-and-Ryanair-460x276.jpg 460w, https://ittn.ie/wp-content/uploads/2020/10/Cork-Airport-Aer-Lingus-and-Ryanair.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /> </div>
<div class="story-contain-text">
<h2>Aviation Authority Aims to Achieve ‘Carbon Neutral’ Status by 2025</h2>
<div class="text-info-contain left relative">
<span class="home-text-author left">Fionn Davenport</span><span class="home-text-date left">September 7, 2021</span>
</div>
</div>
</a>
<div class="read-share-overlay">
<div class="read-more-box-wrapper">
<a href="https://ittn.ie/news/aviation-authority-aims-to-achieve-carbon-neutral-status-by-2025/" rel="bookmark"><span class="read-more-box">Read More</span></a>
</div>
<div class="share-box-wrapper">
<div class="read-more-fb">
<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://ittn.ie/news/aviation-authority-aims-to-achieve-carbon-neutral-status-by-2025/&amp;t=Aviation Authority Aims to Achieve ‘Carbon Neutral’ Status by 2025', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><i class="fa fa-facebook fa-2"></i></a>
</div>
<div class="read-more-twit">
<a href="#" onclick="window.open('http://twitter.com/share?text=Aviation Authority Aims to Achieve ‘Carbon Neutral’ Status by 2025 -&amp;url=https://ittn.ie/news/aviation-authority-aims-to-achieve-carbon-neutral-status-by-2025/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><i class="fa fa-twitter fa-2"></i></a>
</div>
<div class="read-more-comment">
<a href="https://ittn.ie/news/aviation-authority-aims-to-achieve-carbon-neutral-status-by-2025//#comments-button"><i class="fa fa-comments fa-2"></i></a>
</div>
</div>
</div>
</div>
</div>
<div id="sidebar-contain">
<div id="sidebar-scroll-wrap">
<span class="sidebar-scroll">Scroll for more <i class="fa fa-caret-down fa-2"></i></span>
</div>
<div id="sidebar-mobi-tab">
<span class="mobi-tab-but">Tap</span>
</div>
<div id="sidebar-main-wrap" class="left relative">
<div id="sidebar-main-ad">
<div class="widget-ad left relative">


<ins data-revive-zoneid="4" data-revive-id="7d44df2311a99ecdba9e72b635283678"></ins>
<script async src="//itt.network/www/delivery/asyncjs.php"></script>
</div>
</div>
<div id="sidebar-widget-wrap" class="left relative">
<div id="sidebar-widget-in" class="left relative">
<div id="text-30" class="sidebar-widget widget_text"><h3 class="sidebar-header left relative"><span>Sign up to our e-Newsletters</span></h3><div class="sidebar-widget-content left relative"> <div class="textwidget"><div class style="height: 520px; background: #ffffff;"><div class="l-center-container"><div class="sc-kAzzGY dLkilY"><img alt="Logo" src="https://img.createsend1.com/static/hsf/j/2A/D73/FFF/C67FD2F38AC4859C/headerImages/210107221126/irishtraveltradenetworklogo.jpg" class="sc-kGXeez iKxzjo" /></div><div><div class="sc-bdVaJa iIDDUy"><div><form class="js-cm-form" id="subForm" class="js-cm-form" action="https://www.createsend.com/t/subscribeerror?description=" method="post" data-id="A61C50BEC994754B1D79C5819EC1255C8DC751E3F4A02968499F87CC0E330AC5E9E6A10AEAC02F4195B8DB24BAD454DE6DAC7BD9D7A7D378FBB6CC7BF2F1B757"><div size="base" class="sc-jzJRlG bMslyb"><div size="small" class="sc-jzJRlG liOVdz"><div><label size="0.875rem" color="#5d5d65" class="sc-gzVnrw dEVaGV">First Name </label><input aria-label="First Name" id="fieldiylyhjh" maxLength="200" name="cm-f-iylyhjh" class="sc-iwsKbI iMsgpL" /></div></div><div size="small" class="sc-jzJRlG liOVdz"><div><label size="0.875rem" color="#5d5d65" class="sc-gzVnrw dEVaGV">Surname </label><input aria-label="Surname" id="fieldiylyhjk" maxLength="200" name="cm-f-iylyhjk" class="sc-iwsKbI iMsgpL" /></div></div><div size="small" class="sc-jzJRlG liOVdz"><div><label size="0.875rem" color="#5d5d65" class="sc-gzVnrw dEVaGV">Company </label><input aria-label="Company" id="fieldiylyhji" maxLength="200" name="cm-f-iylyhji" class="sc-iwsKbI iMsgpL" /></div></div><div size="small" class="sc-jzJRlG liOVdz"><div><label size="0.875rem" color="#5d5d65" class="sc-gzVnrw dEVaGV">Email <span class="sc-dnqmqq iFTUZ">*</span></label><input autoComplete="Email" aria-label="Email" id="fieldEmail" maxLength="200" name="cm-gttiyu-gttiyu" required type="email" class="js-cm-email-input qa-input-email sc-iwsKbI iMsgpL" /></div></div><div size="base" class="sc-jzJRlG bMslyb"></div></div><button size="1rem" color="#fff" type="submit" class="js-cm-submit-button sc-jKJlTe feeCGs">Subscribe</button></form></div></div></div></div></div><style>.iIDDUy { background: rgb(255, 255, 255); border-radius: 0.3125rem; max-width: 35.25rem; margin-left: auto; margin-right: auto; padding: 2.5rem 2.75rem; position: relative; }.dEVaGV { font-family: Helvetica, Arial, sans-serif; color: rgb(93, 93, 101); display: block; font-size: 0.875rem; font-weight: 400; margin-bottom: 0.5rem; }.iFTUZ { color: rgb(221, 54, 42); }.iMsgpL { appearance: none; background-color: rgb(255, 255, 255); border: 0px; border-radius: 0.1875rem; box-sizing: border-box; box-shadow: rgba(142, 154, 173, 0.1) 0px 2px 0px 0px inset, rgb(210, 215, 223) 0px 0px 0px 1px inset, rgb(255, 255, 255) 0px 1px 0px 0px; color: rgb(67, 77, 93); font-size: 0.875rem; line-height: 1.5; min-height: 2.8125rem; outline: 0px; padding: 0.75rem 1rem; transition: box-shadow 0.2s ease 0s; width: 100%; }.iMsgpL:focus { box-shadow: transparent 0px 0px 0px 0px inset, rgb(80, 156, 246) 0px 0px 0px 1px inset, rgba(80, 156, 246, 0.25) 0px 0px 0px 2px; }.bMslyb { margin-bottom: 1.5rem; }.liOVdz { margin-bottom: 1rem; }.hmAVkF { margin-bottom: 0rem; }.dLkilY { margin-left: auto; margin-right: auto; max-width: 29.125rem; }.iKxzjo { display: block; margin: 0px auto; max-width: 100%; max-height: 7.5rem; }.eaMVYB { background-color: rgb(248, 44, 161); border: none; border-radius: 3px; color: rgb(255, 255, 255); display: inline-block; font-family: Helvetica, Arial, sans-serif; font-size: 14px; font-style: normal; font-weight: 700; line-height: 1; outline: 0px; padding: 0.75rem 1.5rem; text-decoration: none; transition: background-color 0.1s ease-in 0s, box-shadow 0.1s ease-in 0s; }.eaMVYB:hover { cursor: pointer; }.feeCGs { background-color: rgb(248, 44, 161); border: none; border-radius: 3px; color: rgb(255, 255, 255); display: inline-block; font-family: Helvetica, Arial, sans-serif; font-size: 1rem; font-style: normal; font-weight: 700; line-height: 1; outline: 0px; padding: 0.75rem 1.5rem; text-decoration: none; transition: background-color 0.1s ease-in 0s, box-shadow 0.1s ease-in 0s; }.feeCGs:hover { cursor: pointer; }a, abbr, address, article, aside, b, blockquote, body, caption, cite, code, dd, details, dialog, div, dl, dt, em, fieldset, figcaption, figure, footer, form, h1, h2, h3, h4, h5, h6, header, html, i, iframe, img, label, legend, li, main, menu, nav, object, ol, p, pre, section, small, span, strong, sub, summary, sup, table, tbody, td, tfoot, th, thead, time, tr, u, ul { border: 0px; margin: 0px; padding: 0px; }*, ::after, ::before { box-sizing: inherit; }html { font-family: "Helvetica Neue", Arial, sans-serif; font-size: 16px; }h1, h2, h3, h4, h5, h6, html { color: rgb(67, 77, 93); font-weight: 400; line-height: 1.5; }a { color: rgb(25, 169, 229); }button, label, p { overflow-wrap: break-word; word-break: break-word; }</style><script src="https://ajax.googleapis.com/ajax/libs/webfont/1.6.26/webfont.js"></script><script>WebFont.load({google:{families:['Lato:900:latin','Lato:300:latin','Playfair+Display:700italic:latin','Merriweather:700:latin','Crete+Round::latin','PT+Sans+Narrow:700:latin']}});</script><script type="text/javascript" src="https://js.createsend1.com/javascript/copypastesubscribeformlogic.js"></script></div>
</div></div> </div>
</div>
</div>
</div> <footer id="foot-wrap" class="left relative">
<div id="foot-leader" class="left relative">


<ins data-revive-zoneid="3" data-revive-id="7d44df2311a99ecdba9e72b635283678"></ins>
<script async src="//itt.network/www/delivery/asyncjs.php"></script>
</div>

<div id="foot-bottom" class="left relative">
<div id="foot-copy" class="left relative">
<p>Copyright © 2021 ittn</p>
</div>
<div id="foot-soc" class="relative">
<ul class="foot-soc-list relative">
<li class="foot-soc-fb">
<a href="https://www.facebook.com/IrishTravelTradeNews" alt="Facebook" target="_blank"><i class="fa fa-facebook-square fa-2"></i></a>
</li>
<li class="foot-soc-twit">
<a href="https://twitter.com/@ittn_ie" alt="Twitter" target="_blank"><i class="fa fa-twitter-square fa-2"></i></a>
</li>
<li class="foot-soc-yt">
<a href="https://www.youtube.com/channel/UCsikaeVh5hJ4RIARpVkFnog" alt="Youtube" target="_blank"><i class="fa fa-youtube-play fa-2"></i></a>
</li>
<li class="foot-soc-link">
<a href="https://www.linkedin.com/company/irish-travel-trade-news/" alt="LinkedIn" target="_blank"><i class="fa fa-linkedin-square fa-2"></i></a>
</li>
<li class="foot-soc-rss">
<a href="https://ittn.ie/feed/rss/" target="_blank"><i class="fa fa-rss-square fa-2"></i></a>
</li>
</ul>
</div>
</div>
</footer> </div>
</div>
</div>
</div>
</div>
</div>
</div>
<div id="prev-next-wrap">
<div id="prev-post-wrap">
<div id="prev-post-arrow" class="relative">
<i class="fa fa-angle-left fa-4"></i>
</div>
<div class="prev-next-text">
<a href="https://ittn.ie/news/ittn-ireland-gets-a-new-name-logo-welcome-to-travel2ireland/" rel="prev">ITTN Ireland Gets a New Name &amp; Logo: Welcome to Travel2Ireland</a> </div>
</div>
<div id="next-post-wrap">
<div id="next-post-arrow" class="relative">
<i class="fa fa-angle-right fa-4"></i>
</div>
<div class="prev-next-text">
<a href="https://ittn.ie/news/tuesday-travel-tips-malta-with-sharon-jordan-of-ittn-roisin-carbery-of-tropical-sky/" rel="next">Tuesday Travel Tips: Malta with Sharon Jordan of ITTN &amp; Roisin Carbery of Tropical Sky</a> </div>
</div>
</div>
</div>
</div>
<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
<script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};/* ]]> */ </script>

<script type='text/javascript' src='https://ittn.ie/wp-includes/js/comment-reply.min.js?ver=5.7.2' id='comment-reply-js'></script>
<script type='text/javascript' id='forms-for-campaign-monitor-ajax-script-public-js-extra'>
/* <![CDATA[ */
var ajax_request = {"ajax_url":"https:\/\/ittn.ie\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://ittn.ie/wp-content/plugins/forms-for-campaign-monitor/forms/views/public/js/app.js?ver=5.7.2' id='forms-for-campaign-monitor-ajax-script-public-js'></script>
<script type='text/javascript' src='https://ittn.ie/wp-content/themes/ittn-2015/js/scripts.js?ver=5.7.2' id='topnews-js'></script>
<script type='text/javascript' src='https://ittn.ie/wp-content/themes/ittn-2015/js/jquery.nicescroll.min.js?ver=5.7.2' id='nicescroll-js'></script>
<script type='text/javascript' src='https://ittn.ie/wp-content/themes/ittn-2015/js/jquery.infinitescroll.min.js?ver=5.7.2' id='infinitescroll-js'></script>
<script type='text/javascript' src='https://ittn.ie/wp-includes/js/wp-embed.min.js?ver=5.7.2' id='wp-embed-js'></script>
<script async="async" type='text/javascript' src='https://ittn.ie/wp-content/plugins/akismet/_inc/form.js?ver=4.1.9' id='akismet-form-js'></script>
</body>
</html>